$re = '/s:(\d+?):\\\\\"(https?:\/\/)?example\.com/m';
$str = 'a:5:{s:5:\\"test1\\";s:35:\\"example.com\\";s:5:\\"test2\\";s:26:\\"foo http://example.com/bar\\";s:11:\\"submit_data\\"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);