$re = '/G\s*e\s*s\s*a\s*m\s*t\s*s\s*u\s*m\s*m\s*e/m';
$str = 'Gesamtsumme
G e s a m t s u m m e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);