// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)G\s*e\s*s\s*a\s*m\s*t\s*s\s*u\s*m\s*m\s*e").unwrap();
let string = "Gesamtsumme
G e s a m t s u m m e";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}