re = /G\s*e\s*s\s*a\s*m\s*t\s*s\s*u\s*m\s*m\s*e/m
str = 'Gesamtsumme
G e s a m t s u m m e'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end