using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(\d)(?:[:-]?\1)*$)([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$";
string input = @"00:00:00:00:00:01
00:00:00:00:00:00
00:00:00:00:00:00
11:11:11:11:11:11
99-99-99-99-99-99
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}