const regex = /^(?!(\d)(?:[:-]?\1)*$)([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(\\d)(?:[:-]?\\1)*$)([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$', 'gm')
const str = `00:00:00:00:00:01
00:00:00:00:00:00
00:00:00:00:00:00
11:11:11:11:11:11
99-99-99-99-99-99
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}