import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(\\d)(?:[:-]?\\1)*$)([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$";
final String string = "00:00:00:00:00:01\n"
+ "00:00:00:00:00:00\n\n"
+ "00:00:00:00:00:00\n"
+ "11:11:11:11:11:11\n"
+ "99-99-99-99-99-99\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}