re = /^(?!(\d)(?:[:-]?\1)*$)([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$/m
str = '00:00:00:00:00:01
00:00:00:00:00:00
00:00:00:00:00:00
11:11:11:11:11:11
99-99-99-99-99-99
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end