using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"PASSWORD\((?i)secret_?(?i)key\:\)";
string input = @"# Match this, underscore included
PASSWORD(secret_key:)
# Match this, no underscore
PASSWORD(SECRETKEY:)
# No match, space not included in pattern
PASSWORD(secret key:)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}