package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)PASSWORD\((?i)secret_?(?i)key\:\)`)
var str = `# Match this, underscore included
PASSWORD(secret_key:)
# Match this, no underscore
PASSWORD(SECRETKEY:)
# No match, space not included in pattern
PASSWORD(secret key:)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}