// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)PASSWORD\((?i)secret_?(?i)key\:\)").unwrap();
let string = "# Match this, underscore included
PASSWORD(secret_key:)
# Match this, no underscore
PASSWORD(SECRETKEY:)
# No match, space not included in pattern
PASSWORD(secret key:)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}