$re = '/PASSWORD\((?i)secret_?(?i)key\:\)/m';
$str = '# Match this, underscore included
PASSWORD(secret_key:)
# Match this, no underscore
PASSWORD(SECRETKEY:)
# No match, space not included in pattern
PASSWORD(secret key:)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);