const regex = /PASSWORD\((?i)secret_?(?i)key\:\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('PASSWORD\\((?i)secret_?(?i)key\\:\\)', 'gm')
const str = `# Match this, underscore included
PASSWORD(secret_key:)
# Match this, no underscore
PASSWORD(SECRETKEY:)
# No match, space not included in pattern
PASSWORD(secret key:)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}