#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d_([a-zA-Z_]+)_[0-9]+_"
Local $sString = " abc_account2621_activity_20161116_20161117_030627_311999667.csv" & @CRLF & _
" abc_account2621_click_2016111606_20161116_221031_311735299.csv" & @CRLF & _
" abc_account2621_impression_2016111605_20161116_221808_311685411.csv" & @CRLF & _
" abc_account2621_rich_media_2016111606_20161116_192542_311735300.csv" & @CRLF & _
" abc_account2621_match_table_actwd342ivity_cats_20161116_20161117_0311_31.csv.gz " & @CRLF & _
" abc_account2621_match_table_activity_tdwypes_20161116_20161117_0342_31.csv.gz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")