import re
regex = re.compile(r"\d_([a-zA-Z_]+)_[0-9]+_")
test_str = (" abc_account2621_activity_20161116_20161117_030627_311999667.csv\n"
" abc_account2621_click_2016111606_20161116_221031_311735299.csv\n"
" abc_account2621_impression_2016111605_20161116_221808_311685411.csv\n"
" abc_account2621_rich_media_2016111606_20161116_192542_311735300.csv\n"
" abc_account2621_match_table_actwd342ivity_cats_20161116_20161117_0311_31.csv.gz \n"
" abc_account2621_match_table_activity_tdwypes_20161116_20161117_0342_31.csv.gz")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")