use strict;
my $str = ' abc_account2621_activity_20161116_20161117_030627_311999667.csv
abc_account2621_click_2016111606_20161116_221031_311735299.csv
abc_account2621_impression_2016111605_20161116_221808_311685411.csv
abc_account2621_rich_media_2016111606_20161116_192542_311735300.csv
abc_account2621_match_table_actwd342ivity_cats_20161116_20161117_0311_31.csv.gz
abc_account2621_match_table_activity_tdwypes_20161116_20161117_0342_31.csv.gz';
my $regex = qr/\d_([a-zA-Z_]+)_[0-9]+_/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}