import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d_([a-zA-Z_]+)_[0-9]+_";
final String string = " abc_account2621_activity_20161116_20161117_030627_311999667.csv\n"
+ " abc_account2621_click_2016111606_20161116_221031_311735299.csv\n"
+ " abc_account2621_impression_2016111605_20161116_221808_311685411.csv\n"
+ " abc_account2621_rich_media_2016111606_20161116_192542_311735300.csv\n"
+ " abc_account2621_match_table_actwd342ivity_cats_20161116_20161117_0311_31.csv.gz \n"
+ " abc_account2621_match_table_activity_tdwypes_20161116_20161117_0342_31.csv.gz";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}