package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(the|my)\b.*?(?P<bar>\S+)\s+Foo`)
var str = `FooFooFoo the FooFoo the Bar Foo
FooFooFoo the FooFoo my Bar Foo
FooFooFoo my FooFoo my Bar Foo
FooFooFoo my FooFoo the Bar Foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}