const regex = new RegExp('\\b(the|my)\\b.*?(?P<bar>\\S+)\\s+Foo', 'gm')
const str = `FooFooFoo the FooFoo the Bar Foo
FooFooFoo the FooFoo my Bar Foo
FooFooFoo my FooFoo my Bar Foo
FooFooFoo my FooFoo the Bar Foo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}