import re
regex = re.compile(r"\b(the|my)\b.*?(?P<bar>\S+)\s+Foo", flags=re.MULTILINE)
test_str = ("FooFooFoo the FooFoo the Bar Foo\n"
"FooFooFoo the FooFoo my Bar Foo\n\n"
"FooFooFoo my FooFoo my Bar Foo\n"
"FooFooFoo my FooFoo the Bar Foo")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")