import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(the|my)\\b.*?(?P<bar>\\S+)\\s+Foo";
final String string = "FooFooFoo the FooFoo the Bar Foo\n"
+ "FooFooFoo the FooFoo my Bar Foo\n\n"
+ "FooFooFoo my FooFoo my Bar Foo\n"
+ "FooFooFoo my FooFoo the Bar Foo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}