$re = '/\b(the|my)\b.*?(?P<bar>\S+)\s+Foo/m';
$str = 'FooFooFoo the FooFoo the Bar Foo
FooFooFoo the FooFoo my Bar Foo
FooFooFoo my FooFoo my Bar Foo
FooFooFoo my FooFoo the Bar Foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);