#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{1,3})( \d{3})+"
Local $sString = "3 200 200" & @CRLF & _
"3 546 789" & @CRLF & _
"3 200 200" & @CRLF & _
"320 320" & @CRLF & _
"32 000" & @CRLF & _
"32 00" & @CRLF & _
"3 200" & @CRLF & _
"320000" & @CRLF & _
"123 23" & @CRLF & _
"123 123" & @CRLF & _
"" & @CRLF & _
"/^(\d{1,3})( \d{3})+/gm" & @CRLF & _
"" & @CRLF & _
"3 200 456" & @CRLF & _
"Arrondis 10 655 à la dizaine près." & @CRLF & _
"" & @CRLF & _
"Arrondis 24 363 à la dizaine de milliers près." & @CRLF & _
"" & @CRLF & _
"Arrondis 48 664 au millier près." & @CRLF & _
"" & @CRLF & _
"Arrondis 93 075 à la centaine près." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")