use strict;
my $str = '3 200 200
3 546 789
3 200 200
320 320
32 000
32 00
3 200
320000
123 23
123 123
/^(\\d{1,3})( \\d{3})+/gm
3 200 456
Arrondis 10 655 à la dizaine près.
Arrondis 24 363 à la dizaine de milliers près.
Arrondis 48 664 au millier près.
Arrondis 93 075 à la centaine près.
';
my $regex = qr/(\d{1,3})( \d{3})+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}