$re = '/(\d{1,3})( \d{3})+/m';
$str = '3 200 200
3 546 789
3 200 200
320 320
32 000
32 00
3 200
320000
123 23
123 123
/^(\\d{1,3})( \\d{3})+/gm
3 200 456
Arrondis 10 655 à la dizaine près.
Arrondis 24 363 à la dizaine de milliers près.
Arrondis 48 664 au millier près.
Arrondis 93 075 à la centaine près.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);