import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,3})( \\d{3})+";
final String string = "3 200 200\n"
+ "3 546 789\n"
+ "3 200 200\n"
+ "320 320\n"
+ "32 000\n"
+ "32 00\n"
+ "3 200\n"
+ "320000\n"
+ "123 23\n"
+ "123 123\n\n"
+ "/^(\\d{1,3})( \\d{3})+/gm\n\n"
+ "3 200 456\n"
+ "Arrondis 10 655 à la dizaine près.\n\n"
+ "Arrondis 24 363 à la dizaine de milliers près.\n\n"
+ "Arrondis 48 664 au millier près.\n\n"
+ "Arrondis 93 075 à la centaine près.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}