const regex = /(\d{1,3})( \d{3})+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,3})( \\d{3})+', 'gm')
const str = `3 200 200
3 546 789
3 200 200
320 320
32 000
32 00
3 200
320000
123 23
123 123
/^(\\d{1,3})( \\d{3})+/gm
3 200 456
Arrondis 10 655 à la dizaine près.
Arrondis 24 363 à la dizaine de milliers près.
Arrondis 48 664 au millier près.
Arrondis 93 075 à la centaine près.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}