using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?>^.*?\K(?:cat|(dog(1|2|3))))(?(1)|$.^)";
string input = @"jump dog1 cat - Good
jump cat run dog1 - Good
jump dog1 dog2 - Bad, it needs to match _dog1 and _dog2
jump dog1 dog2 cat run dog3 - Bad, it needs to match _dog1, _dog2 and not _dog3
(?>^.*?\K(?:cat|(dog(1|2|3))))(?(1)|$.^)
(?>^.*?\K(?:cat|(\bdog(1|2|3))))
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}