import Foundation
let pattern = #"(?>^.*?\K(?:cat|(dog(1|2|3))))(?(1)|$.^)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
jump dog1 cat - Good
jump cat run dog1 - Good
jump dog1 dog2 - Bad, it needs to match _dog1 and _dog2
jump dog1 dog2 cat run dog3 - Bad, it needs to match _dog1, _dog2 and not _dog3
(?>^.*?\K(?:cat|(dog(1|2|3))))(?(1)|$.^)
(?>^.*?\K(?:cat|(\bdog(1|2|3))))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)