re = /(?>^.*?\K(?:cat|(dog(1|2|3))))(?(1)|$.^)/m
str = 'jump dog1 cat - Good
jump cat run dog1 - Good
jump dog1 dog2 - Bad, it needs to match _dog1 and _dog2
jump dog1 dog2 cat run dog3 - Bad, it needs to match _dog1, _dog2 and not _dog3
(?>^.*?\\K(?:cat|(dog(1|2|3))))(?(1)|$.^)
(?>^.*?\\K(?:cat|(\\bdog(1|2|3))))
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end