use strict;
my $str = 'jump dog1 cat - Good
jump cat run dog1 - Good
jump dog1 dog2 - Bad, it needs to match _dog1 and _dog2
jump dog1 dog2 cat run dog3 - Bad, it needs to match _dog1, _dog2 and not _dog3
(?>^.*?\\K(?:cat|(dog(1|2|3))))(?(1)|$.^)
(?>^.*?\\K(?:cat|(\\bdog(1|2|3))))
';
my $regex = qr/(?>^.*?\K(?:cat|(dog(1|2|3))))(?(1)|$.^)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}