re = /\b0|([^\d*\.?\d*])/
str = '0wqeqweqwe1545513@2sa1f65.2100231wefdsfr
213123safwdas@asf.2ef3
210.850'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end