using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?(\S+@\S+\.\S+:\S+)";
string substitution = @"$1\n";
string input = @"Post Code: abc111
EmailPass : test_111@hotmail.com:password222$£*!
Post Code: abc222
EmailPass : test_222@gmail.:password222$£*!
Post Code: abc111
EmailPass : test_111@hotmail.com:
Post Code: abc111
EmailPass : test_222@hotmail.com:password333$£*!";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}