$re = '/.*?(\S+@\S+\.\S+:\S+)/ms';
$str = 'Post Code: abc111
EmailPass : test_111@hotmail.com:password222$£*!
Post Code: abc222
EmailPass : test_222@gmail.:password222$£*!
Post Code: abc111
EmailPass : test_111@hotmail.com:
Post Code: abc111
EmailPass : test_222@hotmail.com:password333$£*!';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;