// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms).*?(\S+@\S+\.\S+:\S+)").unwrap();
let string = "Post Code: abc111
EmailPass : test_111@hotmail.com:password222$£*!
Post Code: abc222
EmailPass : test_222@gmail.:password222$£*!
Post Code: abc111
EmailPass : test_111@hotmail.com:
Post Code: abc111
EmailPass : test_222@hotmail.com:password333$£*!";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}