const regex = /.*?(\S+@\S+\.\S+:\S+)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(\\S+@\\S+\\.\\S+:\\S+)', 'gms')
const str = `Post Code: abc111
EmailPass : test_111@hotmail.com:password222\$£*!
Post Code: abc222
EmailPass : test_222@gmail.:password222\$£*!
Post Code: abc111
EmailPass : test_111@hotmail.com:
Post Code: abc111
EmailPass : test_222@hotmail.com:password333\$£*!`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);