import Foundation
let pattern = #".*?(\S+@\S+\.\S+:\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Post Code: abc111
EmailPass : test_111@hotmail.com:password222$£*!
Post Code: abc222
EmailPass : test_222@gmail.:password222$£*!
Post Code: abc111
EmailPass : test_111@hotmail.com:
Post Code: abc111
EmailPass : test_222@hotmail.com:password333$£*!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)