using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span[^<>]*\bclass=""[^""]*(?<class>email_[^\s""]+)[^""]*"">\h*(?<mail>[^\s@]+@[^\s@]+)\h*<\/span>";
string input = @"<span class="" xx email_xx xx ""> test@test.test </span>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}