import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span[^<>]*\\bclass=\"[^\"]*(?<class>email_[^\\s\"]+)[^\"]*\">\\h*(?<mail>[^\\s@]+@[^\\s@]+)\\h*<\\/span>";
final String string = "<span class=\" xx email_xx xx \"> test@test.test </span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}