$re = '`<span[^<>]*\bclass="[^"]*(?<class>email_[^\s"]+)[^"]*">\h*(?<mail>[^\s@]+@[^\s@]+)\h*<\/span>`m';
$str = '<span class=" xx email_xx xx "> test@test.test </span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);