re = /<span[^<>]*\bclass="[^"]*(?<class>email_[^\s"]+)[^"]*">\h*(?<mail>[^\s@]+@[^\s@]+)\h*<\/span>/m
str = '<span class=" xx email_xx xx "> test@test.test </span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end