package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0([7,8,9])([0,1])\d{8}$|234([7,8,9])([0,1])\d{8}$`)
var str = `08062242801
+2340862242901
6754
2340862242901
+2348062242901
2349162242901
18062242901
08062242801
08262242801
08162242801
08562242801
080622428011
09162242801
07262242801
07062242801
09262242801
07562242801
06062242801
+2344045751111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}