import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "0([7,8,9])([0,1])\\d{8}$|234([7,8,9])([0,1])\\d{8}$";
final String string = "08062242801\n"
+ "+2340862242901\n"
+ "6754\n"
+ "2340862242901\n"
+ "+2348062242901\n"
+ "2349162242901\n"
+ "18062242901\n"
+ "08062242801\n"
+ "08262242801\n"
+ "08162242801\n"
+ "08562242801\n"
+ "080622428011\n"
+ "09162242801\n"
+ "07262242801\n"
+ "07062242801\n"
+ "09262242801\n"
+ "07562242801\n"
+ "06062242801\n"
+ "+2344045751111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}