import Foundation
let pattern = #"0([7,8,9])([0,1])\d{8}$|234([7,8,9])([0,1])\d{8}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
08062242801
+2340862242901
6754
2340862242901
+2348062242901
2349162242901
18062242901
08062242801
08262242801
08162242801
08562242801
080622428011
09162242801
07262242801
07062242801
09262242801
07562242801
06062242801
+2344045751111
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)