import re
regex = re.compile(r"0([7,8,9])([0,1])\d{8}$|234([7,8,9])([0,1])\d{8}$", flags=re.MULTILINE)
test_str = ("08062242801\n"
"+2340862242901\n"
"6754\n"
"2340862242901\n"
"+2348062242901\n"
"2349162242901\n"
"18062242901\n"
"08062242801\n"
"08262242801\n"
"08162242801\n"
"08562242801\n"
"080622428011\n"
"09162242801\n"
"07262242801\n"
"07062242801\n"
"09262242801\n"
"07562242801\n"
"06062242801\n"
"+2344045751111")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")