using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+ ){4}people";
string input = @"This is a complex topic, which periodically comes up among IT-specialists, a lot has been said about it, but for ""non-IT-specialists"" a lot can be news. Both for those who want to ""get into IT"" and for those who by the nature of their work have to work together with IT services. Some things will be obvious to <> IT people, but not obvious to others. Sometimes because of their!=< lack of understanding, people make painful mistakes. Not only and not so much with their careers, but they bet on the wrong people in their business. So, let's break this issue down without emotion and in language that is understandable to non-specialists.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}