const regex = /(\w+ ){4}people/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+ ){4}people', 'gm')
const str = `This is a complex topic, which periodically comes up among IT-specialists, a lot has been said about it, but for "non-IT-specialists" a lot can be news. Both for those who want to "get into IT" and for those who by the nature of their work have to work together with IT services. Some things will be obvious to <> IT people, but not obvious to others. Sometimes because of their!=< lack of understanding, people make painful mistakes. Not only and not so much with their careers, but they bet on the wrong people in their business. So, let's break this issue down without emotion and in language that is understandable to non-specialists.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}