// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+ ){4}people").unwrap();
let string = "This is a complex topic, which periodically comes up among IT-specialists, a lot has been said about it, but for \"non-IT-specialists\" a lot can be news. Both for those who want to \"get into IT\" and for those who by the nature of their work have to work together with IT services. Some things will be obvious to <> IT people, but not obvious to others. Sometimes because of their!=< lack of understanding, people make painful mistakes. Not only and not so much with their careers, but they bet on the wrong people in their business. So, let's break this issue down without emotion and in language that is understandable to non-specialists.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}