import Foundation
let pattern = #"(\w+ ){4}people"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"This is a complex topic, which periodically comes up among IT-specialists, a lot has been said about it, but for "non-IT-specialists" a lot can be news. Both for those who want to "get into IT" and for those who by the nature of their work have to work together with IT services. Some things will be obvious to <> IT people, but not obvious to others. Sometimes because of their!=< lack of understanding, people make painful mistakes. Not only and not so much with their careers, but they bet on the wrong people in their business. So, let's break this issue down without emotion and in language that is understandable to non-specialists."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)