use strict;
my $str = 'This is a complex topic, which periodically comes up among IT-specialists, a lot has been said about it, but for "non-IT-specialists" a lot can be news. Both for those who want to "get into IT" and for those who by the nature of their work have to work together with IT services. Some things will be obvious to <> IT people, but not obvious to others. Sometimes because of their!=< lack of understanding, people make painful mistakes. Not only and not so much with their careers, but they bet on the wrong people in their business. So, let\'s break this issue down without emotion and in language that is understandable to non-specialists.';
my $regex = qr/(\w+ ){4}people/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}